use strict;
my $str = 'nFamily n49 new nTom';
my $regex = qr/\bn(?=[A-Z0-9])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";