#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=@3=)(\w++).+>>.+(?<=@3=)(?(1)(?!\1@4)\w++|\w++)"
Local $sString = "@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c1@4=d" & @CRLF & _
"@1=a@2=b@3=c1@4=d >> @1=a@2=b@3=c@4=d" & @CRLF & _
"@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c@4=d" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")