$re = '/(?<=@3=)(\w++).+>>.+(?<=@3=)(?(1)(?!\1@4)\w++|\w++)/m';
$str = '@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c1@4=d
@1=a@2=b@3=c1@4=d >> @1=a@2=b@3=c@4=d
@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c@4=d
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);