using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@3=)(\w++).+>>.+(?<=@3=)(?(1)(?!\1@4)\w++|\w++)";
string input = @"@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c1@4=d
@1=a@2=b@3=c1@4=d >> @1=a@2=b@3=c@4=d
@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c@4=d
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}