import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=@3=)(\\w++).+>>.+(?<=@3=)(?(1)(?!\\1@4)\\w++|\\w++)";
final String string = "@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c1@4=d\n"
+ "@1=a@2=b@3=c1@4=d >> @1=a@2=b@3=c@4=d\n"
+ "@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c@4=d\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}