const regex = /(?<=@3=)(\w++).+>>.+(?<=@3=)(?(1)(?!\1@4)\w++|\w++)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=@3=)(\\w++).+>>.+(?<=@3=)(?(1)(?!\\1@4)\\w++|\\w++)', 'gm')
const str = `@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c1@4=d
@1=a@2=b@3=c1@4=d >> @1=a@2=b@3=c@4=d
@1=a@2=b@3=c@4=d >> @1=a@2=b@3=c@4=d
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}