using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+?)\s(\d+?)\s(.+?)\s(.+?)\s(.+?)\s(.*?\.)$";
string input = @"10 10 ""u"" ""E2U+sip"" ""!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!"" .
100 10 ""s"" ""x-eduroam:radius.tls"" "" _radsec._tcp.roaming.ja.net.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}