use strict;
my $str = '10 10 "u" "E2U+sip" "!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!" .
100 10 "s" "x-eduroam:radius.tls" "" _radsec._tcp.roaming.ja.net.';
my $regex = qr/^(\d+?)\s(\d+?)\s(.+?)\s(.+?)\s(.+?)\s(.*?\.)$/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}