import re
regex = re.compile(r"^(\d+?)\s(\d+?)\s(.+?)\s(.+?)\s(.+?)\s(.*?\.)$", flags=re.MULTILINE)
test_str = ("10 10 \"u\" \"E2U+sip\" \"!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!\" .\n"
"100 10 \"s\" \"x-eduroam:radius.tls\" \"\" _radsec._tcp.roaming.ja.net.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")