import re
regex = re.compile(r"^JML\s*\|.*\s*\r?\n((?:.*\r?\n)*?)Authors\b", flags=re.MULTILINE)
test_str = ("--- JOURNAL of MEDICINE and LIFE\n\n"
"JML | REVIEW\n\n"
"The role of novel poly (ADP-ribose) inhibitors in the treatment of locally advanced and metastatic Her-2/neu negative breast cancer with inherited germline BRCA1/2 mutations. A review of the literature\n\n"
"Authors list, etc, etc ---\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")