re = /^JML\s*\|.*\s*\r?\n((?:.*\r?\n)*?)Authors\b/m
str = '--- JOURNAL of MEDICINE and LIFE
JML | REVIEW
The role of novel poly (ADP-ribose) inhibitors in the treatment of locally advanced and metastatic Her-2/neu negative breast cancer with inherited germline BRCA1/2 mutations. A review of the literature
Authors list, etc, etc ---
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end