#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bEUR *\d+(?:[ \d]*\d)?\b|\b(\d+(?: +\d+)*)\b"
Local $sString = "I want it to not match:" & @CRLF & _
"" & @CRLF & _
"EUR 10 000" & @CRLF & _
"And I want it to match the numbers in the following cases:" & @CRLF & _
"" & @CRLF & _
"{3} " & @CRLF & _
"10 000 " & @CRLF & _
"347835"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")