import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bEUR *\\d+(?:[ \\d]*\\d)?\\b|\\b(\\d+(?: +\\d+)*)\\b";
final String string = "I want it to not match:\n\n"
+ "EUR 10 000\n"
+ "And I want it to match the numbers in the following cases:\n\n"
+ "{3} \n"
+ "10 000 \n"
+ "347835";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}