use strict;
my $str = 'I want it to not match:
EUR 10 000
And I want it to match the numbers in the following cases:
{3}
10 000
347835';
my $regex = qr/\bEUR *\d+(?:[ \d]*\d)?\b|\b(\d+(?: +\d+)*)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}