$re = '/\bEUR *\d+(?:[ \d]*\d)?\b|\b(\d+(?: +\d+)*)\b/m';
$str = 'I want it to not match:
EUR 10 000
And I want it to match the numbers in the following cases:
{3}
10 000
347835';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);