import re
regex = re.compile(r"\bEUR *\d+(?:[ \d]*\d)?\b|\b(\d+(?: +\d+)*)\b", flags=re.MULTILINE)
test_str = ("I want it to not match:\n\n"
"EUR 10 000\n"
"And I want it to match the numbers in the following cases:\n\n"
"{3} \n"
"10 000 \n"
"347835")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")