# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a.*?href="https?:\\/\\/(?:www\.)?youtube\.com[^"]+".*?>(.*?)<\\/a>/$1/gm;t' <<< "Here is some content and a <a href=\"https://www.youtube.com/watch?v=f0cReHKUiJM\">video link</a>.
Here is more content with another <a href=\"https://www.youtube.com/watch?v=09123asgjnib\">video link</a>."