package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a.*?href="https?:\/\/(?:www\.)?youtube\.com[^"]+".*?>(.*?)<\/a>`)
var str = `Here is some content and a <a href="https://www.youtube.com/watch?v=f0cReHKUiJM">video link</a>.
Here is more content with another <a href="https://www.youtube.com/watch?v=09123asgjnib">video link</a>.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}