use strict;
my $str = 'Here is some content and a <a href="https://www.youtube.com/watch?v=f0cReHKUiJM">video link</a>.
Here is more content with another <a href="https://www.youtube.com/watch?v=09123asgjnib">video link</a>.';
my $regex = qr/<a.*?href="https?:\/\/(?:www\.)?youtube\.com[^"]+".*?>(.*?)<\/a>/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";