re = /<a.*?href="https?:\/\/(?:www\.)?youtube\.com[^"]+".*?>(.*?)<\/a>/m
str = 'Here is some content and a <a href="https://www.youtube.com/watch?v=f0cReHKUiJM">video link</a>.
Here is more content with another <a href="https://www.youtube.com/watch?v=09123asgjnib">video link</a>.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result