const regex = /<a.*?href="https?:\/\/(?:www\.)?youtube\.com[^"]+".*?>(.*?)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?href="https?:\\\/\\\/(?:www\\.)?youtube\\.com[^"]+".*?>(.*?)<\\\/a>', 'gm')
const str = `Here is some content and a <a href="https://www.youtube.com/watch?v=f0cReHKUiJM">video link</a>.
Here is more content with another <a href="https://www.youtube.com/watch?v=09123asgjnib">video link</a>.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);