import re
regex = re.compile(r"^[1-9]\d{0,2}(\.\d{3})*,\d{2}$", flags=re.MULTILINE)
test_str = ("99999A123\n"
"7.300.250,00\n"
"21.000,00\n"
"123,12\n"
"01,12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")