#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[#baz\].*?\[\/baz\]|(\[[^\]]*\])"
Local $sString = "Text text text [foo] text text text" & @CRLF & _
"" & @CRLF & _
"Text text text [bar] text text text" & @CRLF & _
"" & @CRLF & _
"Text text text [#baz] [nope] [/baz] text text text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")