package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[#baz\].*?\[\/baz\]|(\[[^\]]*\])`)
var str = `Text text text [foo] text text text
Text text text [bar] text text text
Text text text [#baz] [nope] [/baz] text text text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}