import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[#baz\\].*?\\[\\/baz\\]|(\\[[^\\]]*\\])";
final String string = "Text text text [foo] text text text\n\n"
+ "Text text text [bar] text text text\n\n"
+ "Text text text [#baz] [nope] [/baz] text text text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}