using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[#baz\].*?\[\/baz\]|(\[[^\]]*\])";
string input = @"Text text text [foo] text text text
Text text text [bar] text text text
Text text text [#baz] [nope] [/baz] text text text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}