$re = '/\[#baz\].*?\[\/baz\]|(\[[^\]]*\])/m';
$str = 'Text text text [foo] text text text
Text text text [bar] text text text
Text text text [#baz] [nope] [/baz] text text text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);