package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`({(.*?(,??)"(Name)":"(.*?)"|"(.*?)":"(.*?)")})`)
var str = `{"ID":"123","Name":"ABC"},{"ID":"234","Name":"BCD"},{"ID":"345","Name":"DEF"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}