// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"({(.*?(,??)"(Name)":"(.*?)"|"(.*?)":"(.*?)")})"#).unwrap();
let string = "{\"ID\":\"123\",\"Name\":\"ABC\"},{\"ID\":\"234\",\"Name\":\"BCD\"},{\"ID\":\"345\",\"Name\":\"DEF\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}