re = /({(.*?(,??)"(Name)":"(.*?)"|"(.*?)":"(.*?)")})/
str = '{"ID":"123","Name":"ABC"},{"ID":"234","Name":"BCD"},{"ID":"345","Name":"DEF"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end