$re = '/({(.*?(,??)"(Name)":"(.*?)"|"(.*?)":"(.*?)")})/';
$str = '{"ID":"123","Name":"ABC"},{"ID":"234","Name":"BCD"},{"ID":"345","Name":"DEF"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);