package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<last_name>\w+),\s(?:(?<title_one>\w+)\s)?(?:(?<title_two>\w+)\s)?(?<first_name>\w+)$`)
var str = `Name: JAMES, 1ST LT LABRON
Name: KNOTS, PFC DON
Name: BUILDER, BOB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}