$re = '/(?<last_name>\w+),\s(?:(?<title_one>\w+)\s)?(?:(?<title_two>\w+)\s)?(?<first_name>\w+)$/m';
$str = 'Name: JAMES, 1ST LT LABRON
Name: KNOTS, PFC DON
Name: BUILDER, BOB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);