import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<last_name>\\w+),\\s(?:(?<title_one>\\w+)\\s)?(?:(?<title_two>\\w+)\\s)?(?<first_name>\\w+)$";
final String string = "Name: JAMES, 1ST LT LABRON\n"
+ "Name: KNOTS, PFC DON\n"
+ "Name: BUILDER, BOB";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}