import re
regex = re.compile(r"(?<last_name>\w+),\s(?:(?<title_one>\w+)\s)?(?:(?<title_two>\w+)\s)?(?<first_name>\w+)$", flags=re.MULTILINE)
test_str = ("Name: JAMES, 1ST LT LABRON\n"
"Name: KNOTS, PFC DON\n"
"Name: BUILDER, BOB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")