re = /(?<last_name>\w+),\s(?:(?<title_one>\w+)\s)?(?:(?<title_two>\w+)\s)?(?<first_name>\w+)$/m
str = 'Name: JAMES, 1ST LT LABRON
Name: KNOTS, PFC DON
Name: BUILDER, BOB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end