# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+\\/).*\?(.*\\/[0-9]+)/$1$2/;t' <<< "http://www.example.com/all-dog-breeds.php?Greater-Swiss-Mountain-Dog/82"