$re = '/(.+\/).*\?(.*\/[0-9]+)/';
$str = 'http://www.example.com/all-dog-breeds.php?Greater-Swiss-Mountain-Dog/82';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;