use strict;
my $str = 'http://www.example.com/all-dog-breeds.php?Greater-Swiss-Mountain-Dog/82';
my $regex = qr/(.+\/).*\?(.*\/[0-9]+)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";