using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+\/).*\?(.*\/[0-9]+)";
string substitution = @"$1$2";
string input = @"http://www.example.com/all-dog-breeds.php?Greater-Swiss-Mountain-Dog/82";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}