#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.+\/).*\?(.*\/[0-9]+)"
Local $sString = "http://www.example.com/all-dog-breeds.php?Greater-Swiss-Mountain-Dog/82"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)