#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\d,]+\h*x\h*([\d,]+)(?:\h*x*[\d,]+)?"
Local $sString = " Matches/Cases | Result |" & @CRLF & _
"|-------------------|--------|" & @CRLF & _
"| 200 x 90 x 14 | 90 |" & @CRLF & _
"| 90x200 | 200 |" & @CRLF & _
"| 200 x 90x20 | 90 |" & @CRLF & _
"| 60,4 x46,5 x 42,6 | 46,5 |" & @CRLF & _
"| 90x190,9 | 190,9 |" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")