re = /[\d,]+\h*x\h*([\d,]+)(?:\h*x*[\d,]+)?/
str = ' Matches/Cases | Result |
|-------------------|--------|
| 200 x 90 x 14 | 90 |
| 90x200 | 200 |
| 200 x 90x20 | 90 |
| 60,4 x46,5 x 42,6 | 46,5 |
| 90x190,9 | 190,9 |
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end