import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d,]+\\h*x\\h*([\\d,]+)(?:\\h*x*[\\d,]+)?";
final String string = " Matches/Cases | Result |\n"
+ "|-------------------|--------|\n"
+ "| 200 x 90 x 14 | 90 |\n"
+ "| 90x200 | 200 |\n"
+ "| 200 x 90x20 | 90 |\n"
+ "| 60,4 x46,5 x 42,6 | 46,5 |\n"
+ "| 90x190,9 | 190,9 |\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}