import re
regex = re.compile(r"[\d,]+\h*x\h*([\d,]+)(?:\h*x*[\d,]+)?")
test_str = (" Matches/Cases | Result |\n"
"|-------------------|--------|\n"
"| 200 x 90 x 14 | 90 |\n"
"| 90x200 | 200 |\n"
"| 200 x 90x20 | 90 |\n"
"| 60,4 x46,5 x 42,6 | 46,5 |\n"
"| 90x190,9 | 190,9 |\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")