package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d,]+\h*x\h*([\d,]+)(?:\h*x*[\d,]+)?`)
var str = ` Matches/Cases | Result |
|-------------------|--------|
| 200 x 90 x 14 | 90 |
| 90x200 | 200 |
| 200 x 90x20 | 90 |
| 60,4 x46,5 x 42,6 | 46,5 |
| 90x190,9 | 190,9 |
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}