#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "url(\((['\" ])*(?!data:|https?:\/\/)([^\"'\)]+)['\" ]*)"
Local $sString = ".nyroModalCloseButton {" & @CRLF & _
" top: -13px;" & @CRLF & _
" right: -13px;" & @CRLF & _
" width: 12px;" & @CRLF & _
" height: 12px;" & @CRLF & _
" text-indent: -9999em;" & @CRLF & _
" background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".nyroModalCloseButton {" & @CRLF & _
" top: -13px;" & @CRLF & _
" right: -13px;" & @CRLF & _
" width: 12px;" & @CRLF & _
" height: 12px;" & @CRLF & _
" text-indent: -9999em;" & @CRLF & _
" background: url(https://instant/templates/_default_/images/nyromodal/close.gif);" & @CRLF & _
"}" & @CRLF & _
".nyroModalCloseButton {" & @CRLF & _
" top: -13px;" & @CRLF & _
" right: -13px;" & @CRLF & _
" width: 12px;" & @CRLF & _
" height: 12px;" & @CRLF & _
" text-indent: -9999em;" & @CRLF & _
" background: url("../instant/templates/_default_/images/nyromodal/close.gif");" & @CRLF & _
"}" & @CRLF & _
"background:url(data:jpg;base64,/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAQDAwMDAwQDAwQFBAMEBQcFBAQFBwgGBgcGBggKCAgICAgICggKCgsKCggNDQ4ODQ0SEhISEhQUFBQUFBQUFBT/2wBDAQUFBQgHCA8KCg8SDwwPEhYVFRUVFhYUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBT/wAARCAApACADAREAAhEBAxEB/8QAFwABAQEBAAAAAAAAAAAAAAAAAAQDBv/EABgQAQEBAQEAAAAAAAAAAAAAAAAScRNh/8QAFwEBAQEBAAAAAAAAAAAAAAAAAAECBv/EABQRAQAAAAAAAAAAAAAAAAAAAAD/2gAMAwEAAhEDEQA/AOQvHYOWLwC8AvAT3jKl4BeAXgMKFKAoCgTdBToB0A6Amv1Gi/QL9Av0GaqAAA//2Q==)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")