import Foundation
let pattern = #"url(\((['\" ])*(?!data:|https?:\/\/)([^\"'\)]+)['\" ]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url("../instant/templates/_default_/images/nyromodal/close.gif");
}
background:url(data:jpg;base64,/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAQDAwMDAwQDAwQFBAMEBQcFBAQFBwgGBgcGBggKCAgICAgICggKCgsKCggNDQ4ODQ0SEhISEhQUFBQUFBQUFBT/2wBDAQUFBQgHCA8KCg8SDwwPEhYVFRUVFhYUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBT/wAARCAApACADAREAAhEBAxEB/8QAFwABAQEBAAAAAAAAAAAAAAAAAAQDBv/EABgQAQEBAQEAAAAAAAAAAAAAAAAScRNh/8QAFwEBAQEBAAAAAAAAAAAAAAAAAAECBv/EABQRAQAAAAAAAAAAAAAAAAAAAAD/2gAMAwEAAhEDEQA/AOQvHYOWLwC8AvAT3jKl4BeAXgMKFKAoCgTdBToB0A6Amv1Gi/QL9Av0GaqAAA//2Q==)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)