const regex = /url(\((['\" ])*(?!data:|https?:\/\/)([^\"'\)]+)['\" ]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url(\\(([\'\\" ])*(?!data:|https?:\\\/\\\/)([^\\"\'\\)]+)[\'\\" ]*)', 'g')
const str = `.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url("../instant/templates/_default_/images/nyromodal/close.gif");
}
background:url(data:jpg;base64,/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAQDAwMDAwQDAwQFBAMEBQcFBAQFBwgGBgcGBggKCAgICAgICggKCgsKCggNDQ4ODQ0SEhISEhQUFBQUFBQUFBT/2wBDAQUFBQgHCA8KCg8SDwwPEhYVFRUVFhYUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBT/wAARCAApACADAREAAhEBAxEB/8QAFwABAQEBAAAAAAAAAAAAAAAAAAQDBv/EABgQAQEBAQEAAAAAAAAAAAAAAAAScRNh/8QAFwEBAQEBAAAAAAAAAAAAAAAAAAECBv/EABQRAQAAAAAAAAAAAAAAAAAAAAD/2gAMAwEAAhEDEQA/AOQvHYOWLwC8AvAT3jKl4BeAXgMKFKAoCgTdBToB0A6Amv1Gi/QL9Av0GaqAAA//2Q==)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}