import re
regex = re.compile(r"url(\((['\" ])*(?!data:|https?:\/\/)([^\"'\)]+)['\" ]*)")
test_str = (".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;\n"
"}\n\n"
".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(https://instant/templates/_default_/images/nyromodal/close.gif);\n"
"}\n"
".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(\"../instant/templates/_default_/images/nyromodal/close.gif\");\n"
"}\n"
"background:url(data:jpg;base64,/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAQDAwMDAwQDAwQFBAMEBQcFBAQFBwgGBgcGBggKCAgICAgICggKCgsKCggNDQ4ODQ0SEhISEhQUFBQUFBQUFBT/2wBDAQUFBQgHCA8KCg8SDwwPEhYVFRUVFhYUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBT/wAARCAApACADAREAAhEBAxEB/8QAFwABAQEBAAAAAAAAAAAAAAAAAAQDBv/EABgQAQEBAQEAAAAAAAAAAAAAAAAScRNh/8QAFwEBAQEBAAAAAAAAAAAAAAAAAAECBv/EABQRAQAAAAAAAAAAAAAAAAAAAAD/2gAMAwEAAhEDEQA/AOQvHYOWLwC8AvAT3jKl4BeAXgMKFKAoCgTdBToB0A6Amv1Gi/QL9Av0GaqAAA//2Q==)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")